GHSA-g5ff-637f-6q2m: LiteLLM let a read-only proxy user read any local file, including the master key, through vertex_ai_credentials
An authenticated LiteLLM proxy user with only the internal_user_viewer role, which many deployments hand out through SSO, could read any file the proxy can read by sending a crafted vertex_ai_credentials value to /utils/transform_request. Reading /proc/self/environ can reveal LITELLM_MASTER_KEY and provider keys, which means full admin control. Fixed in LiteLLM 1.95.0. A separate reflected XSS in /sso/debug/callback was fixed in 1.85.0.
What it is
GHSA-g5ff-637f-6q2m (LiteLLM before 1.95.0): the request-body blocklist rejected vertex_credentials but not its alias vertex_ai_credentials, so the value reached the Vertex AI credential loader, which read a local file and sent it to an attacker-controlled URL.
The advisory says there is no reliable configuration workaround on affected versions; the fix adds the alias to the blocklist.
GHSA-hhww-mrg2-969h (LiteLLM 1.65.5 to before 1.85.0): the unauthenticated /sso/debug/callback endpoint put identity-provider fields into an inline script without HTML escaping, so a display name containing </script> could run JavaScript on the proxy origin. An attacker with an account on the same IdP could send the callback link to a logged-in admin and take over their session.
How to check
- Affected: litellm (PyPI) before 1.95.0 for the file read, and 1.65.5 to before 1.85.0 for the XSS.
- You are most exposed if you run the LiteLLM proxy with SSO or other low-privilege user accounts.
How to fix
- Upgrade litellm to 1.95.0 or later.
- If a viewer-level account you don't fully trust used an older proxy, rotate LITELLM_MASTER_KEY and the provider API keys in the proxy's environment.
pip show litellm | grep -i version
pip install -U 'litellm>=1.95.0' Sources
- criticalCVE-2026-114612: LiteLLM proxy lets an internal user forge an admin token and run commands
- criticalLiteLLM 1.107.0 on PyPI and Docker was malware: a credential stealer that runs whenever Python starts
- criticalCVE-2026-37004: LiteLLM vulnerable to server-side template injection in the /prompts/test endpoint
- criticalCVE-2026-49468: LiteLLM: Authentication Bypass via Host Header Injection