CVE-2026-75913: CodeWhale (formerly DeepSeek-TUI) auto-approved git_show lets prompt injection write arbitrary files, plus an unprompted shell input bug
Two CodeWhale advisories (published on GitHub in July 2026, CVEs in August) show auto-approved tools in the DeepSeek coding agent doing more than the user agreed to. A prompt-injected model can pass --output= to git_show and write any file without a prompt, and can type commands into an already approved interactive shell. Both are fixed in CodeWhale 0.8.64; the deprecated deepseek-tui Rust crate has no fixed release.
What it is
CVE-2026-75913 (GHSA-7j5w-7r7x-9v27, critical): git_show passes the model's rev value straight into git show. A value starting with --output= is read as a flag, so the tool writes a file of the attacker's choosing. The tool is auto-approved and labelled read-only, so the user sees no prompt.
With a malicious repository plus prompt injection, that write can target files such as ~/.ssh/authorized_keys.
CVE-2026-75857 (GHSA-g29h-pfmp-qp9r, high): exec_shell needs approval, but its sibling exec_shell_interact is auto-approved. Once the user approves a long-running shell such as python3 -i, mysql, ssh or sudo -i, the model can send any input into it without another prompt.
Affected: the deepseek-tui Rust crate and npm package before 0.8.41 (from 0.3.27 for git_show and 0.3.10 for exec_shell_interact) and codewhale-tui 0.8.41 up to 0.8.64.
How to check
- Run codewhale --version or deepseek-tui --version. Anything below 0.8.64 for CodeWhale, or any deepseek-tui crate install, is affected.
- Look for unexpected changes to ~/.ssh/authorized_keys, shell profiles or git hooks on machines where the agent ran on untrusted repositories.
How to fix
- Move to CodeWhale 0.8.64 or later. The npm deepseek-tui package is deprecated in favour of codewhale.
- Uninstall the deprecated deepseek-tui Rust crate, which has no fixed release.
- Avoid leaving privileged interactive shells (sudo -i, database clients, ssh) open inside an agent session.
npm uninstall -g deepseek-tui
npm install -g codewhale
codewhale --version # should be 0.8.64 or later